Ambiera Forum

Discussions, Help and Support.

Ambiera Forum > CopperCube > Feature requests and bug reports
FPS Camera - Walking Down a Slope is Jerky

argentarts
Registered User
Quote
2018-07-25 22:15:31

Hello. I've been working with CopperCube 6 and enjoying the experience. One thing I've noticed, however, is that walking down a slope is a bit jerky (i.e. the camera "bumps" a bit as if getting snagged or caught on something). Walking UP the same slope is smooth.

Is there any way to fix this?

Thanks.


dartagnan
Registered User
Quote
2018-07-25 23:37:38

haven't got into this yet, but have you tried EnableInclination option in the the Collide when moved behavior?or you can just enable physics simulation if you are only targeting Mac and Windows.


argentarts
Registered User
Quote
2018-07-26 00:23:32

Hi dartagnan. Thanks for responding.

When I enable EnableInclination, it doesn't remove the jerk on the way down a slope. In the third person terrain example, it makes things worse because the player model does some pretty trippy stuff on the way up and down the slope. ;)

When I create a terrain (default settings) and add a FPS camera, checking EnableInclination does not help.

When I turn on physics simulation, the FPS camera sometimes gets temporarily stuck going down a slope if there is a change in the slope direction.

So, neither of these seem to be a solution.


dartagnan
Registered User
Quote
2018-07-26 02:22:38

for the inclination solution, you can perhaps get around by attaching a separate hidden or invisble mesh as collision which will only handle the collide and move behavior. As for only getting the position and not rotation, you can search for this as I'm also trying to find one later on.

physics method works for me, just make some adjustment on the collision sphere size in collide when moved option. The only another issue I can find is not having any option for friction.


Robo
Guest
Quote
2020-12-06 12:10:27

I found changing gravity from 10 to 2 made a big difference.

I also found Direct3D was a problem.

If you don't have vertical synchronization selected you get best frame rate but also see screen tear (transparent line going up the screen).

If you tick vertical synchronization then stops the screen tear but also reduces the frame rate about 25%.

Only solution is NOT to use Direct3D and use OpenGL - so much better !


Robo
Guest
Quote
2020-12-08 00:50:52

Actually with a single terrain texture, OpenGL works very well. Once you add more than one texture to the terrain you get some of the textures glitched and pixelated....at least I did...cant find any solution to this as yet....

ps - a gravity of 1.5 was a nice balance also to stop jittery movements....


Create reply:


Posted by: (you are not logged in)


Enter the missing letter in: "Internat?onal" (you are not logged in)


Text:

 

  

Possible Codes


Feature Code
Link [url] www.example.com [/url]
Bold [b]bold text[/b]
Image [img]http://www.example.com/image.jpg[/img]
Quote [quote]quoted text[/quote]
Code [code]source code[/code]

Emoticons


   






Copyright© Ambiera e.U. all rights reserved.
Privacy Policy | Terms and Conditions | Imprint | Contact